We are currently experiencing issues with SR Health
Incident Report for SR Health
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 12:36 MST
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2021 - 12:06 MST
Monitoring
Our cloud hosting provider is experiencing a major outage impacting SR Health and many other sites. SR Health appears to be operational currently and we are continuing to monitor.
Posted Nov 16, 2021 - 11:16 MST
Investigating
We are currently investigating this issue.
Posted Nov 16, 2021 - 10:50 MST
This incident affected: SR Health Platform - Platform access and overall performance.